Top Groups

Discussions

Musescore.com .mxl Download sometimes creates invalid dates in archive

When downloading certain scores as compressed MusicXML from musescore.com, the date of files in the mxl archive is invalid (00-00-1980).

Exporting to .mxl from MuseScore 3.0.2.20666 and 3.0.4 does create a valid date (current one).

This, for example, leads to an Error in a System Library in C# (ZipStorer), unfortunately. Of course, they should have better error handling and ignore invalid dates. (Using ZipArchive instead of ZipStorer is a solution here)

Still, i think MuseScore shouldn't set invalid dates.
If no date is available, it should give a default valid date (e.g. 01/01/1980 instead of 00/00/1980).
Sample score with invalid date in .mxl download:
https://musescore.com/user/11881/scores/4982061

(unfortunately i could not find a simpler score with this issue yet)
Most other scores have valid dates in the .mxl.
unzip -v output on the .mxl:

Length   Method    Size  Cmpr    Date    Time   CRC-32   Name
--------  ------  ------- ---- ---------- ----- --------  ----
    145  Defl:N      109  25% 00-00-1980 00:00 b76825c4  META-INF/container.xml
2099134  Defl:N    87092  96% 00-00-1980 00:00 80183128  score.xml
--------          -------  ---                            -------
2099279            87201  96%                            2 files


I initially posted this on the musescore.org forums:
https://musescore.org/en/node/285351#comment-900820

Thanks for your attention.

RECURRING audio & uploading issue

So, my most recent piece Fuscous currently has no audio, even though when I uploaded it last night, it did. The audio quality was not the same as when I listened to it on musescore, it sounded like a 240p version of the soundfont. Can anyone help me here?

Also, I need to upload pieces 4-5 times before they'll even correctly work with audio, and with Fuscous, it took me 8 tries.
How can this be fixed?

"Send to YouTube" function truncates description

The "Send to YouTube" function appears to incorrectly truncate the description sent to YouTube to ~1,990 characters. Of the last three scores sent, the descriptions have been truncated to 1992, 1988 & 1997 characters respectively.

YouTube allows  5,000 characters in the description.

This arbitrary  limit requires me to edit each VideoScore sent to YouTube and replace the truncated description with the original one; an error-prone additional step.

Play uploaded score on musescore.com with Apple

I'm testing musescore.com as an environment for uploading rehearsal files for our choir. 
On a PC scores play okay after you set the audio source to synth so you can listen to your own part (SATB).
When we do this on an Apple Ipad or Imac there is no sound at all.
You can only play with Musescore audio source but then you get all the parts instead of separate parts.

Anyone know a solution for this problem?

Score Playback on Mobile

I don’t know if anyone else is having this issue, but whenever I play a score on MuseScore in the browser (Safari for example), the score will play, but then it will just jump back to the beginning after a while. I even tried downloading the MP3 file on my phone, but it does the same thing. Is it something with my phone or what’s going on here? Thanks!

Unfixed Piano Roll issues

So I posted two separate issues with the piano roll feature (the first one was fixed within a week but the second one has yet to be fixed even though I was told they were aware and would look into it). The Piano Roll seems to breeze through section breaks when you put them into scores. That's all lol (just wanted to post a reminder discussion)

Example here: https://musescore.com/astronix2/disbelief---phases-1--2