Audio didn't update when score updated.

Dec 10, 2018

https://musescore.com/user/1831606/scores/5346131  I changed the tempo at the second system frm 60 to 50, and the webpage is still playing at 60 and the pink-block tracking is at 50 and out of sync.  What infinite, bottomless, daily brokenness.  Not getting better.


Comments

@eagri1967 me too and the only way is deleteting the old version but then we lose comments and views etc.
@eagri1967 Give a link to your score which connected with this issue, please.
@Victor78
https://musescore.com/user/8752261/scores/4552521 ("Miniature...") - updated, now it is played with no sound
https://musescore.com/user/8752261/scores/5351119 ("Sadness") - had to replace the original score to meet the contest deadline.
I'm at work - if you need further examples, I'll need more time and will let you have some examples this evening, but this means ruining the history of further of my pieces, so I'd do that if necessary only. Pls let me know whether the above scores are sufficient or you need more scores to check.
@eagri1967 It's sufficient for now, thank you!
@Victor78
I have another score where the soundfont differs, but the custom audio won't update:
https://musescore.com/user/8752261/scores/3753486/s/c5625e .
Here is the link to the audio file (mp3) that sounds different:
https://drive.google.com/file/d/1tGKiZp9TaV-jUvfDmG4YVWxcZbLmqVea/view?usp=sharing
@Victor78
Amy changes made re. this issues in the meantimw?
@Howard_C. Do you have the issue with your score yet?
@Victor78 Yes. Still affecting when I re-uploaded it 2 minutes ago.
Normally when I do a tempo change I just have to click it again a couple times for it to work. I would recommend that a after you type in the tempo number, deselect it an select it again.
No. It works perfectly in my local copy (in MS3). It even shows correctly online, but the mp3 has not been updated.
@BSG Does audio still not update?
@Victor78 It`s about replacing a short piece with a longer piece. still not working. You can see the score but won`t hear the audio in the extension .All they have to do is to replace the old audio with the new audio. They replace the score but not the audio.
@The Horse Give the examples of your problem scores
@Ali Yüklet Do you have the issue with your score yet?
@Victor78 Hi. My latest score's playback is acting very strangely: The pink box follows the repeat sign at the end of the score but the audio follows the D.C. sign and ignores the repeat and 2nd volta altogether. There's no problem when I play the score with the software. Here's the score: https://musescore.com/user/204621/scores/5362273
@Rivergrove got it, we will fix it too. Thank you for feedback!
@BSG it's fixed, please check.
@Victor78 This one is fixed. I'll post here if I encounter others where the problem persists.
Yes, still broken. https://musescore.com/user/1831606/scores/5346131 is still at 60, not 50 as it shows (just tried); from MS3. Just tried to upload it. Could you please look at THAT SCORE and figure out why the MP3 is 2 days out of date? Thanks.
What's more, I just tried to update a private score (https://musescore.com/user/30560276/scores/5347376) and even the visual score failed to change. The change was trivial (non-sound-affecting), but that's no excuse. This is with MS 3.
This seemed most similar thread, my custom (live-o) audio is now back in sync with the online score! Can't speak for new updates of custom audio/re-updates, but the old audios going out of sync is fixed for me.
I gratuitously modified the score (some piano-roll editing) to make a midi file difference, and re-uploaded. No change. The audio file is yet another day older. Is anybody listening, do you not understand what is happening, are you all on vacation, or do you simply not care? Please understand my anger and frustration.
I'm still experiencing troubles as well. I can upload a score newly, this seems to work, but the moment I try to update an existing score, this doesn't work. Either the audio and video are out of sync, or - today - even after several trials to replace the existing score, nothing happened when pressing the 'play' button. Again I had to delete the score and upload it newly. On writing to support I got the reply that the problem had been fixed and I should try again. So I wrote again with an example including score file, secret link, as well as a link to the sound file exported from the musescore program. Hopefully someone of the support team looks into the matter again...
This problem is still happening and is driving me crazy. Is it so hard for you to fix this? I mean, I have allergic rhinitis and it become more serious when I am unhappy. It causes me to do weird things like playing with trousers zipper in front of a fire extinguisher. I don't want to go to mental asylums so please fix this problem. Thank you.
@I Eat Toothpaste give the examples of your problem scores, please.
22.12.2018 I have the same problem. Score changes when updated but audio stays the same like before. (https://musescore.com/user/37957/scores/5355018)
MS 2.3.2 Rev 4592407, Mint 18.4
Hi, I'm also having this issue with https://musescore.com/node/5354208 – it keeps reverting to the audio for the version where I accidentally muted the melody lines in the mixer (I've uploaded it 11 times and only one of the revisions should have had that issue), and I don't know how to fix that. It works immediately after I update the score but after a while the server seems to go back to the old audio. Could a moderator fix this? Thanks.
@Potato! at the Chips this appears to be a widespread issue that needs to be fixed in general. up until now, it seems they've been doing things on a case-by-case basis, but this is hardly a long-term solution.
@tburch @Victor78 How about a button on the "Update" page that forces immediate recomputation of the audio until this problem is truly solved?
Found some missing/wrong notes in my transcriptions so decided to update them today, starting with this: https://musescore.com/user/9996931/scores/2583031
...only to find that the audio didn't update and both the piano roll and piano keyboard play an E-F dyad in the left hand of Bar 6 (at the second 8th note) like in the old version while I made it an E only in the current version.
For posterity's sake, I may as well record my audio-not-matching problem with this: https://musescore.com/user/9996931/scores/5085205
I added D's in the right hand of Bars 18 and 19 and they're not appearing in the audio, piano roll, or piano keyboard.
And another audio mismatch problem with this: https://musescore.com/user/9996931/scores/5268843
I made the last right-hand chord in Bar 50 an actual (rolled) chord instead of just a single E, but only the single E is in the audio/piano roll/piano keyboard.
@Victor78. Are you and the other staff members working on fixing the "audio doesn't update" problem? There are many people suffering from it, including myself. Doing it case-by-case isn't going to help anyone, and it will just create more work for you guy.
What worries me is that I was able to consistently trigger audio mismatches with updates three times today. I used Firefox on a Windows 10 desktop to update my scores. Is this problem somehow fixed on Chrome but not Firefox (given the number of times it's said this problem has been fixed)?
My score is having the same issues as above. The audio that plays is from the original score and not the updated. Could anyone fix this please? Thank you.
https://musescore.com/krazsk/welcome-to-the-family
We are working on this issue. It's connected with the infrastructure of cdn servers.
We found the solution, now this issue is resolved as I can see.
I'm asking you to check your problematic scores. Is this fix actual for everyone?
If no, give me details please.
@Victor78 my score mentioned above is fixed now. i haven't tried a new update, but the sheet now matches the music. thanks!
@Victor78
It's odd--on all 3 of my affected scores, the audio is fixed as far as I can tell, but none of the piano roll or piano keyboard images are. All of those images still reflect the old versions.
@Victor78
I confirm that the piano roll and keyboard images have been fixed for all 3 of my scores. Thanks!
@Victor78
https://musescore.com/user/8752261/scores/4552521
("Miniature...") - after saving online and refreshing the score page, this one seems ok.
https://musescore.com/user/8752261/scores/3753486/s/c5625e
seems to have updated re. sound.
I go on checking further ones tomorrow because I'm dead tired. Thank you for your efforts so far.

Your comment

Only members of a group can post to group discussions, so Join Audio didn't update when score updated.